Home Forums Technical Support Custom jQuery Speed Issue

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  Louis Alviss 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16550

    I have been adding some custom jQuery that replace the “Files Included” div and when you refresh the page it takes a few seconds to replace the content. This is a big problem as well when I am trying to replace big bold text because it appears somewhere for a second then moves a second later which looks bad. Is there a way to put the custom jQuery maybe somewhere in the theme files to load faster?

    Refresh this page to see what I am talking about.

     

    https://dev.modeldezign.com/product/soundress-hq-soundpack/

     

    Thank you very much for reading 🙂

    #16561

    Hi,

    Did you try to add the code in the Appearance > Customizer > System > Custom JS area ?

    Thank you

    #16564

    Yes thats where I added it, and it is quite slow so I thought maybe there might be a place in the backend to add it to make it faster? Do you have any suggestions?

     

    Thanks.

    #16567

    Hi,

    Well, it’s the best place already, you can also try to compress the JS and enable the cache on your site.

    Thank you

    #16580

    Ok thanks a lot for clearing that up. I would like to exclude the internal javascript file in the customize area. What is the file manager location of this file so I can add it to the “Excluded JavaScript Files” section of my WPRocket caching plugin?

    Thanks again.

    Attachments:
    You must be logged in to view attached files.
    #16588

    Hi,

    It doesn’t have any file because the custom js you added to the Custom JS area will be loaded directly in the HTML source of the site which means “internal” as you understood correctly ” the internal javascript file in the customize area”

    That option is “Excluded JavaScript Files” not for internal

    Thank you

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.